import Foundation
let pattern = #".*(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABC123456789A9876
ABCD1234567890F23
1234ABC4567JIJLMN
ABCDEFG1234-!.567
12345660703J1A501F4Z2051
1234ABCLDlZd1523
1234ABCLDlZd15
ABC1234
ABC1234ABC1234A
ABC123ABC123A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)