using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\d{4})";
string input = @"ABC123456789A9876
ABCD1234567890F23
1234ABC4567JIJLMN
ABCDEFG1234-!.567
12345660703J1A501F4Z2051
1234ABCLDlZd1523
1234ABCLDlZd15
ABC1234
ABC1234ABC1234A
ABC123ABC123A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}