#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))"
Local $sString = "table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><strong>Name 1</strong></td>" & @CRLF & _
" <td>Info and ignore <a href="/gohere"/>this</a></td>" & @CRLF & _
" <td><a href="MySpecialAction?list=10000">Edit</a></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><strong>Name 2</strong></td>" & @CRLF & _
" <td>Info and ignore <a href="/gohere"/>this</a></td>" & @CRLF & _
" <td><a href="MySpecialAction?field=&list=10001">Edit</a></td>" & @CRLF & _
" </tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td><strong>Name 2</strong></td>" & @CRLF & _
" <td>Info and ignore <a href="/gohere"/>this</a></td>" & @CRLF & _
" <td><a href="MySpecialAction?field=&list=10002&something=whatever">Edit</a></td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")