import re
regex = re.compile(r"(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|\"myspecialaction\?.*?list=(?<id>[^&\"]+))", flags=re.IGNORECASE)
test_str = ("table>\n"
" <tr>\n"
" <td><strong>Name 1</strong></td>\n"
" <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
" <td><a href=\"MySpecialAction?list=10000\">Edit</a></td>\n"
" </tr>\n"
" <tr>\n"
" <td><strong>Name 2</strong></td>\n"
" <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
" <td><a href=\"MySpecialAction?field=&list=10001\">Edit</a></td>\n"
" </tr>\n"
"<tr>\n"
" <td><strong>Name 2</strong></td>\n"
" <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
" <td><a href=\"MySpecialAction?field=&list=10002&something=whatever\">Edit</a></td>\n"
" </tr>\n"
"</table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")