using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|""myspecialaction\?.*?list=(?<id>[^&""]+))";
string input = @"table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href=""/gohere""/>this</a></td>
<td><a href=""MySpecialAction?list=10000"">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href=""/gohere""/>this</a></td>
<td><a href=""MySpecialAction?field=&list=10001"">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href=""/gohere""/>this</a></td>
<td><a href=""MySpecialAction?field=&list=10002&something=whatever"">Edit</a></td>
</tr>
</table>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}