import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<strong\\b[^>]*>(?<name>.*?)<\\/strong>|\"myspecialaction\\?.*?list=(?<id>[^&\"]+))";
final String string = "table>\n"
+ " <tr>\n"
+ " <td><strong>Name 1</strong></td>\n"
+ " <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
+ " <td><a href=\"MySpecialAction?list=10000\">Edit</a></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td><strong>Name 2</strong></td>\n"
+ " <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
+ " <td><a href=\"MySpecialAction?field=&list=10001\">Edit</a></td>\n"
+ " </tr>\n"
+ "<tr>\n"
+ " <td><strong>Name 2</strong></td>\n"
+ " <td>Info and ignore <a href=\"/gohere\"/>this</a></td>\n"
+ " <td><a href=\"MySpecialAction?field=&list=10002&something=whatever\">Edit</a></td>\n"
+ " </tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}