const regex = /(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<strong\\b[^>]*>(?<name>.*?)<\\\/strong>|"myspecialaction\\?.*?list=(?<id>[^&"]+))', 'gi')
const str = `table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?list=10000">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10001">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10002&something=whatever">Edit</a></td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}