// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))"#).unwrap();
let string = "table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href=\"/gohere\"/>this</a></td>
<td><a href=\"MySpecialAction?list=10000\">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href=\"/gohere\"/>this</a></td>
<td><a href=\"MySpecialAction?field=&list=10001\">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href=\"/gohere\"/>this</a></td>
<td><a href=\"MySpecialAction?field=&list=10002&something=whatever\">Edit</a></td>
</tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}