$re = '/(?:<strong\b[^>]*>(?<name>.*?)<\/strong>|"myspecialaction\?.*?list=(?<id>[^&"]+))/i';
$str = 'table>
<tr>
<td><strong>Name 1</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?list=10000">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10001">Edit</a></td>
</tr>
<tr>
<td><strong>Name 2</strong></td>
<td>Info and ignore <a href="/gohere"/>this</a></td>
<td><a href="MySpecialAction?field=&list=10002&something=whatever">Edit</a></td>
</tr>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);