# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="wp-caption">([\s\S]*?)<\/div>/<figure>$1<\/figure>/g;t' <<< "
<div class=\"wp-caption\">
<a href=\"https://\">
<img src=\"https://\" alt=\"blabla\">
</a>
</div>"