package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class="wp-caption">([\s\S]*?)</div>`)
var str = `
<div class="wp-caption">
<a href="https://">
<img src="https://" alt="blabla">
</a>
</div>`
var substitution = "<figure>$1</figure>"
fmt.Println(re.ReplaceAllString(str, substitution))
}