const regex = new RegExp('<div class="wp-caption">([\\s\\S]*?)</div>', 'g')
const str = `
<div class="wp-caption">
<a href="https://">
<img src="https://" alt="blabla">
</a>
</div>`;
const subst = `<figure>$1</figure>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);