use strict;
my $str = '
<div class="wp-caption">
<a href="https://">
<img src="https://" alt="blabla">
</a>
</div>';
my $regex = qr~<div class="wp-caption">([\s\S]*?)</div>~p;
my $subst = '<figure>$1</figure>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";