$re = '~<div class="wp-caption">([\s\S]*?)</div>~';
$str = '
<div class="wp-caption">
<a href="https://">
<img src="https://" alt="blabla">
</a>
</div>';
$subst = "<figure>$1</figure>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;