using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""wp-caption"">([\s\S]*?)</div>";
string substitution = @"<figure>$1</figure>";
string input = @"
<div class=""wp-caption"">
<a href=""https://"">
<img src=""https://"" alt=""blabla"">
</a>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}