// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class="wp-caption">([\s\S]*?)</div>"#).unwrap();
let string = "
<div class=\"wp-caption\">
<a href=\"https://\">
<img src=\"https://\" alt=\"blabla\">
</a>
</div>";
let substitution = "<figure>$1</figure>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}