import Foundation
let pattern = #"<div class="wp-caption">([\s\S]*?)</div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="wp-caption">
<a href="https://">
<img src="https://" alt="blabla">
</a>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<figure>$1</figure>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)