#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<div class="wp-caption">([\s\S]*?)</div>"
Local $sString = "" & @CRLF & _
"<div class="wp-caption">" & @CRLF & _
" <a href="https://">" & @CRLF & _
" <img src="https://" alt="blabla">" & @CRLF & _
" </a>" & @CRLF & _
"</div>"
Local $sSubst = "<figure>$1</figure>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)