# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/BE(.*?)ÿ//g;t' <<< "38.254:23BE;ãjhÿ04
BE–¼4²ÿ
BE¼%ºÿ
BE¯™„Hÿ
BE:™•@ÿ
BEh^Îÿ"