import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BE(.*?)ÿ";
final String string = "38.254:23BE;ãjhÿ04\n"
+ "BE–¼4²ÿ\n"
+ "BE¼%ºÿ\n"
+ "BE¯™„Hÿ\n"
+ "BE:™•@ÿ\n"
+ "BEh^Îÿ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}