re = /BE(.*?)ÿ/
str = '38.254:23BE;ãjhÿ04
BE–¼4²ÿ
BE¼%ºÿ
BE¯™„Hÿ
BE:™•@ÿ
BEh^Îÿ'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result