# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"BE(.*?)ÿ"
test_str = ("38.254:23BE;ãjhÿ04\n"
"BE–¼4²ÿ\n"
"BE¼%ºÿ\n"
"BE¯™„Hÿ\n"
"BE:™•@ÿ\n"
"BEh^Îÿ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.