const regex = /BE(.*?)ÿ/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('BE(.*?)ÿ', 'g')
const str = `38.254:23BE;ãjhÿ04
BE–¼4²ÿ
BE¼%ºÿ
BE¯™„Hÿ
BE:™•@ÿ
BEh^Îÿ`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);