$re = '/BE(.*?)ÿ/';
$str = '38.254:23BE;ãjhÿ04
BE–¼4²ÿ
BE¼%ºÿ
BE¯™„Hÿ
BE:™•@ÿ
BEh^Îÿ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;