#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?"
Local $sString = "funcA(param0,param1,param2,param3);" & @CRLF & _
"funcA(param0,param1,param2,param3, param4);" & @CRLF & _
"funcA(param0, param1);" & @CRLF & _
"funcA(param0);" & @CRLF & _
"funcA(param0,param1,param2,param3);" & @CRLF & _
""
Local $sSubst = "if(isTrue) funcB($1, funcC($2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)