// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?").unwrap();
let string = "funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
";
let substitution = "if(isTrue) funcB($1, funcC($2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}