import Foundation
let pattern = #"^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"if(isTrue) funcB($1, funcC($2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)