$re = '/^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?/m';
$str = 'funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
';
$subst = "if(isTrue) funcB($1, funcC($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;