const regex = /^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *funcA *\\(([^,\\s;)]*) *(?:, *([^)\\;]+))?', 'gm')
const str = `funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
`;
const subst = `if(isTrue) funcB($1, funcC($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);