package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?`)
var str = `funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
`
var substitution = "if(isTrue) funcB($1, funcC($2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}