import re
regex = re.compile(r"^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?", flags=re.MULTILINE)
test_str = ("funcA(param0,param1,param2,param3);\n"
"funcA(param0,param1,param2,param3, param4);\n"
"funcA(param0, param1);\n"
"funcA(param0);\n"
"funcA(param0,param1,param2,param3);\n")
subst = "if(isTrue) funcB($1, funcC($2)"
result = regex.sub(subst, test_str)
if result:
print(result)