import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\D+)(\\d+)(?=((?!\\)).)*\\(|[^()]*$)";
final String string = "1Hello2Hai (in 2:3) 3hi 4 bye";
final String subst = "$1\\n$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}