re = /(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)/
str = '1Hello2Hai (in 2:3) 3hi 4 bye'
subst = '$1\\n$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result