import Foundation
let pattern = #"(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1Hello2Hai (in 2:3) 3hi 4 bye"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)