const regex = /(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\D+)(\\d+)(?=((?!\\)).)*\\(|[^()]*$)', 'g')
const str = `1Hello2Hai (in 2:3) 3hi 4 bye`;
const subst = `$1\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);