$re = '/(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)/';
$str = '1Hello2Hai (in 2:3) 3hi 4 bye';
$subst = "$1\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;