import re
regex = re.compile(r"(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)")
test_str = "1Hello2Hai (in 2:3) 3hi 4 bye"
subst = "$1\\n$2"
result = regex.sub(subst, test_str)
if result:
print(result)