using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?";
string input = @"http://user:password@www.example.com
https://www.example.com/some/path?query=foo
https://www.example.com/some/path
http://www.example.com/some/path
https://example.com/some/path
http://example.com/some/path
https://example.com/
http://example.com/
www.example.com/some/path
www.example.com
www.example.com/
example.com/some/path
example.com
subdomain.example.com
example.co.uk
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}