use strict;
my $str = 'http://user:password@www.example.com
https://www.example.com/some/path?query=foo
https://www.example.com/some/path
http://www.example.com/some/path
https://example.com/some/path
http://example.com/some/path
https://example.com/
http://example.com/
www.example.com/some/path
www.example.com
www.example.com/
example.com/some/path
example.com
subdomain.example.com
example.co.uk
';
my $regex = qr/(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}