// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?").unwrap();
let string = "http://user:password@www.example.com
https://www.example.com/some/path?query=foo
https://www.example.com/some/path
http://www.example.com/some/path
https://example.com/some/path
http://example.com/some/path
https://example.com/
http://example.com/
www.example.com/some/path
www.example.com
www.example.com/
example.com/some/path
example.com
subdomain.example.com
example.co.uk
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}