import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\\.)?(?P<domain>[\\w\\.]+)(?P<path_query>/?.*)?";
final String string = "http://user:password@www.example.com\n"
+ "https://www.example.com/some/path?query=foo\n"
+ "https://www.example.com/some/path\n"
+ "http://www.example.com/some/path\n"
+ "https://example.com/some/path\n"
+ "http://example.com/some/path\n"
+ "https://example.com/\n"
+ "http://example.com/\n"
+ "www.example.com/some/path\n"
+ "www.example.com\n"
+ "www.example.com/\n"
+ "example.com/some/path\n"
+ "example.com\n"
+ "subdomain.example.com\n"
+ "example.co.uk\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}