import re
regex = re.compile(r"(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?")
test_str = ("http://user:password@www.example.com\n"
"https://www.example.com/some/path?query=foo\n"
"https://www.example.com/some/path\n"
"http://www.example.com/some/path\n"
"https://example.com/some/path\n"
"http://example.com/some/path\n"
"https://example.com/\n"
"http://example.com/\n"
"www.example.com/some/path\n"
"www.example.com\n"
"www.example.com/\n"
"example.com/some/path\n"
"example.com\n"
"subdomain.example.com\n"
"example.co.uk\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")