package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?`)
var str = `http://user:password@www.example.com
https://www.example.com/some/path?query=foo
https://www.example.com/some/path
http://www.example.com/some/path
https://example.com/some/path
http://example.com/some/path
https://example.com/
http://example.com/
www.example.com/some/path
www.example.com
www.example.com/
example.com/some/path
example.com
subdomain.example.com
example.co.uk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}