re = /(?P<schema>.*:\/\/)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>\/?.*)?/
str = 'http://user:password@www.example.com
https://www.example.com/some/path?query=foo
https://www.example.com/some/path
http://www.example.com/some/path
https://example.com/some/path
http://example.com/some/path
https://example.com/
http://example.com/
www.example.com/some/path
www.example.com
www.example.com/
example.com/some/path
example.com
subdomain.example.com
example.co.uk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end