# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/, \d{4}(?:-\d{2})?$//gm;t' <<< "Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate's degree, 2000
Percent of adults with a bachelor's degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate's degree, 2014-18"