use strict;
my $str = 'Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate\'s degree, 2000
Percent of adults with a bachelor\'s degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate\'s degree, 2014-18';
my $regex = qr/, \d{4}(?:-\d{2})?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";