$re = '/, \d{4}(?:-\d{2})?$/m';
$str = 'Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate\'s degree, 2000
Percent of adults with a bachelor\'s degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate\'s degree, 2014-18';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;