const regex = /, \d{4}(?:-\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', \\d{4}(?:-\\d{2})?$', 'gm')
const str = `Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate's degree, 2000
Percent of adults with a bachelor's degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate's degree, 2014-18`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);