import Foundation
let pattern = #", \d{4}(?:-\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate's degree, 2000
Percent of adults with a bachelor's degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate's degree, 2014-18
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)