import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ", \\d{4}(?:-\\d{2})?$";
final String string = "Percent of adults with a high school diploma only, 2000\n"
+ "Percent of adults completing some college or associate's degree, 2000 \n"
+ "Percent of adults with a bachelor's degree or higher, 2000\n"
+ "Percent of adults with less than a high school diploma, 2014-18\n"
+ "Percent of adults with a high school diploma only, 2014-18\n"
+ "Percent of adults completing some college or associate's degree, 2014-18";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}